What operating systems are supported, what are the minimum requirements?

Xpert-Timer requires approx. 50MB RAM. In order to run the program you need Windows XP, Windows Vista, Windows 7 or Windows8. You can use a terminal server to run Xpert-Timer. If you want to store the data on a SQL Server, please use Version 2008 or 2012 of SQL. The free Express version for SQL works fine with Xpert-Timer.