System requirements

RAM

Xpert-Timer Enterprise, Pro and Basic requires approx. 50MB RAM.

Supported operating systems

In order to run the program you need Windows XP, Windows Vista, Windows 7, Windows8 or Windows 10.

Compatible databases

You can use a terminal server to run Xpert-Timer. If you want to store the data on a SQL Server, please use version 2008, 2012 or 2014 of MS-SQL or use a MySQL database. The free Express version of MS-SQL works fine with Xpert-Timer.